gmt

Install command:
brew install gmt

Also known as: gmt@6

Tools for manipulating and plotting geographic and Cartesian data

https://www.generic-mapping-tools.org/

License: LGPL-3.0-or-later

/api/formula-linux/gmt.json (JSON API)

/api/bottle-linux/gmt.json (Bottle JSON API)

Linux formula code on GitHub

Bottle (binary package) not available on this platform.

Current versions:

stable 6.2.0
head ⚡️ HEAD

Other versions:

gmt@5 5.4.5 Tools for manipulating and plotting geographic and Cartesian data

Revision: 1

Depends on:

fftw 3.3.10 C routines to compute the Discrete Fourier Transform
gdal 3.3.2 Geospatial Data Abstraction Library
netcdf 4.8.1 Libraries and data formats for array-oriented scientific data
pcre2 10.38 Perl compatible regular expressions library with a new API

Depends on when building from source:

cmake 3.21.3 Cross-platform make
GMT needs Ghostscript for the 'psconvert' command to convert PostScript files
to other formats. To use 'psconvert', please 'brew install ghostscript'.

GMT needs FFmpeg for the 'movie' command to make movies in MP4 or WebM format.
If you need this feature, please 'brew install ffmpeg'.

GMT needs GraphicsMagick for the 'movie' command to make animated GIFs.
If you need this feature, please 'brew install graphicsmagick'.

Analytics:

Installs (30 days)
gmt 2
Installs on Request (30 days)
gmt 2
Build Errors (30 days)
gmt 0
Installs (90 days)
gmt 5
Installs on Request (90 days)
gmt 4
Installs (365 days)
gmt 41
gmt --HEAD 3
Installs on Request (365 days)
gmt 32
gmt --HEAD 3
Fork me on GitHub