ruby-build

Install command:
brew install ruby-build

Install various Ruby versions and implementations

https://github.com/rbenv/ruby-build

License: MIT

/api/formula/ruby-build.json (JSON API)

Formula code on GitHub

Current versions:

stable 20201118
head ⚡️ HEAD

Depends on:

autoconf 2.69 Automatic configure script builder
pkg-config 0.29.2 Manage compile and link flags for libraries
readline 8.0.4 Library for command-line editing
ruby-build installs a non-Homebrew OpenSSL for each Ruby version installed and these are never upgraded.

To link Rubies to Homebrew's OpenSSL 1.1 (which is upgraded) add the following
to your /Users/runner/.bash_profile:
    export RUBY_CONFIGURE_OPTS="--with-openssl-dir=$(brew --prefix openssl@1.1)"

Note: this may interfere with building old versions of Ruby (e.g <2.4) that use
OpenSSL <1.1.

Analytics:

Installs (30 days)
ruby-build 61,709
ruby-build --HEAD 319
Installs on Request (30 days)
ruby-build 22,879
ruby-build --HEAD 318
Build Errors (30 days)
ruby-build --HEAD 2
Installs (90 days)
ruby-build 173,373
ruby-build --HEAD 663
Installs on Request (90 days)
ruby-build 66,027
ruby-build --HEAD 656
Installs (365 days)
ruby-build 696,191
ruby-build --HEAD 2,108
Installs on Request (365 days)
ruby-build 249,513
ruby-build --HEAD 2,047
Fork me on GitHub