python@3.11

Install command:
brew install python@3.11

Interpreted, interactive, object-oriented programming language

https://www.python.org/

License: Python-2.0

Formula JSON API: /api/formula/python@3.11.json

Bottle JSON API: /api/bottle/python@3.11.json

Formula code: python@3.11.rb on GitHub

Bottle (binary package) installation support provided for:

Intel ventura
monterey
big sur
catalina
64-bit linux
Apple Silicon ventura
monterey
big sur

Current versions:

stable 3.11.0

Other versions:

python@3.10 3.10.8 Interpreted, interactive, object-oriented programming language
python@3.9 3.9.15 Interpreted, interactive, object-oriented programming language
python@3.8 3.8.15 Interpreted, interactive, object-oriented programming language
python@3.7 3.7.15 Interpreted, interactive, object-oriented programming language

Depends on:

mpdecimal 2.5.1 Library for decimal floating point arithmetic
openssl@1.1 1.1.1s Cryptography and SSL/TLS Toolkit
sqlite 3.40.0 Command-line interface for SQLite
xz 5.2.7 General-purpose data compression with high compression ratio

Depends on when building from source:

pkg-config 0.29.2 Manage compile and link flags for libraries
Python has been installed as
    $(brew --prefix)/bin/python3.11

Unversioned and major-versioned symlinks `python`, `python3`, `python-config`, `python3-config`, `pip`, `pip3`, etc. pointing to
`python3.11`, `python3.11-config`, `pip3.11` etc., respectively, have been installed into
    $(brew --prefix)/opt/python@3.11/libexec/bin

If you do not need a specific version of Python, and always want Homebrew's `python3` in your PATH:
    brew install python3

You can install Python packages with
    pip3.11 install <package>
They will install into the site-package directory
    $(brew --prefix)/lib/python3.11/site-packages

tkinter is no longer included with this formula, but it is available separately:
    brew install python-tk@3.11

gdbm (`dbm.gnu`) is no longer included in this formula, but it is available separately:
    brew install python-gdbm@3.11
`dbm.ndbm` changed database backends in Homebrew Python 3.11.
If you need to read a database from a previous Homebrew Python created via `dbm.ndbm`,
you'll need to read your database using the older version of Homebrew Python and convert to another format.
`dbm` still defaults to `dbm.gnu` when it is installed.

For more information about Homebrew and Python, see: https://docs.brew.sh/Homebrew-and-Python

Analytics (macOS):

Installs (30 days)
python@3.11 307,796
Installs on Request (30 days)
python@3.11 10,205
Build Errors (30 days)
python@3.11 200
Installs (90 days)
python@3.11 313,693
Installs on Request (90 days)
python@3.11 15,162
Installs (365 days)
python@3.11 313,693
Installs on Request (365 days)
python@3.11 15,162

Analytics (Linux):

Installs (30 days)
python@3.11 6,943
Installs on Request (30 days)
python@3.11 232
Build Errors (30 days)
python@3.11 16
Installs (90 days)
python@3.11 7,039
Installs on Request (90 days)
python@3.11 322
Installs (365 days)
python@3.11 7,039
Installs on Request (365 days)
python@3.11 322
Fork me on GitHub